Aggiornamento

MPLAB X_parte 1

Riferimento versione 3.20

Apertura di un progetto e impiego del simulatore

L’ambiente di sviluppo MPLAB viene gradualmente rinnovato e sostituito da una nuova
versione denominata MPLAB X, utilizzabile con i sistemi operativi Windows, Linux e Mac.
La novita piu evidente di MPLAB X & un diverso aspetto dell'IDE.

Il progetto che si realizza non €& legato soltanto al compilatore utilizzato ma anche al

programmer/debugger.
Nel passaggio da una versione all’altra Microchip ha reso
con la vecchia versione, progetti che si possono importare

mantenendo intatte pero le prerogative di ciascun ambiente.

E' possibile quindi lavorare su uno stesso progetto

compatibili i progetti realizzati
e convertire per il nuovo IDE,

con entrambe le versioni;

I'aggiornamento dei sorgenti non preclude la visualizzazione degli stessi nei differenti IDE.

Chi, per diversi motivi, decide di continuare a lavorare con

la vecchia versione Microchip

mantiene ancora, allo stato attuale, la possibilita di scaricare una versione in lento

sviluppo.
In figura 1 vengono riportate le icone di due versioni.
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Figura 1

Pagina iniziale

La pagina iniziale (Start Page) di MPLAB X viene riprodotta in figura 2.
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Selezionando Learn & Discover e di seguito Quick Start o Get Started (figura 3) si ha
accesso a due guide semplificate (in lingua inglese) che consentono un primo approccio
allambiente di sviluppo.
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Figura 3

Gli argomenti contenuti nella guida Quick Start vengono sintetizzati in figura 4.

Quick Start for Embedded Development in MPLAB X IDE

To quickly get started with MPLAB X IDE, follow the steps below:
+ Preliminaries
* Creating a New Project - All development within MPLAB X IDE requires a project.
= Adding Source Code to the Project
+ Verifying Language Tool Locations and Building the Project
» Venfying Hardware Tool Communication
» Debugging the Project Output
= Changing Hardware Tool or Compiler Properties

= Building and Debugging — A Special Note
+ Getting More Help

Figura 4
Apertura di un progetto
Per aprire un nuovo progetto dalla Start Page si pud procedere in uno dei due modi

seguenti (figura 5):

- selezionando File e di seguito New Project dal menu a tendina;
- facendo clik sullicona corrispondente situata nella barra sottostante .
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Figura 5



Con lapertura di un progetto si ha accesso alla finestra New Project riportata
parzialmente in figura 6.
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Figura 6

La definizione di un progetto prevede sette step successivi (non tutti necessari per la
definizione del medesimo) e I'apertura delle finestre corrispondenti.

Di seguito vengono presi in considerazione soltanto gli step necessari per realizzare un
progetto con il microcontrollore 16F84A.

E’ il programma stesso che durante la fase di definizione di un progetto salta gli step che
non sono necessari, in questo caso il 3 e il 5.

Step 1_Choose Project (figura 7)
Consente la selezione della categoria (in questo caso Microchip Embedded) e del tipo di
progetto (in questo caso Standalone Projects).

3 New Project x
Steps ‘Choose Project
[
1. Choose Project Q Fiter:
b7
Categories: Projects:
[ icr ochip Embedded (&) Standalone Project
i [ Other Embedded [&d Existing MPLAB IDE va Project
51 Samples IS Prebuilt (Hex, Loadable Image) Project

(& User Makefile Project
[ Library Project

Description:

Creates a new standalone application project. It uses an IDE-generated makefile to build your
project.

Finish Cancel Help
Figura 7

Step 2_Select Device (figura 8)
Consente la selezione del microcontrollore che si intende utilizzare (famiglia e sigla del
dispositivo, in questo caso 16F84A).

3 tew Project X

Steps Select Device

1. Choose Project

2. Select Device

3. SelectHeader Family: All Families| “
4. Select Tool

5. Select Plugin Board

8,
7.

Select Compiler Device: PIC16F84A @

Select Project Mame and
Folder

< Back Finish Cancel Help
Figura 8




Step 4_Select Tool (figura 9)
Viene scelto lo strumento (tool) con il quale programmare, in questo caso il simulatore
(Simulator) messo a disposizione dal programma per verificare la correttezza del software.
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Figura 9

Step 6_Select Compiler (figura 10)
Viene scelto il compilatore, in questo caso mpasm.

3 New Project X
Steps Select G

1. Choose Project

2. Select Device Compiler Toclchains

3. SelectHeader I HITECH PICC

g- ge:ecglool _— ¢ | o HITECH PICC (v2.83) [C:\Program Files (x86)\HI TECH Software PICC|2.831bin]

. Select Plugin Boart o HI 5 i - ’ ?
6. Select Compiler @ HI-TECH PICC (v9.82) [C:\Program Files (x86)HI-TECH Software \PICC\2.82'bin]
7. Select Project Mame and 2
Folder i Ea¥mpasm (v5.65) [C:\Program Files (x86) Microchip\MPLABX \v 3. 20\mpasmx]
+.-%C8 (None found)

< Back Finish Cancel

Figura 10

Step 7_Select Project Name and Folder (figura 11)
Viene scelto il nome del progetto e la posizione della cartella che contiene tutti i file di
progetto.

3 New Project X

Steps Select Project Name and Folder

Choose Project
Select Device
Select Header
Select Toal

Select Plugin Board
Select Compiler .
Select Project Hame and Praject Folder: C:\Users\Desktop\progetto1.X
Folder

Project Name: progettol

Project Location: C:\Users!Desktop Browse...

N

Overwrite existing project.
Also delete sources,

Set as main project

[] Lise project location as the project folder:

Encoding: 1S0-8859-1 ~

< Back Mext > Cancel Help
Figura 11




Una volta definito il progetto compare sulla sinistra la finestra Projects (figura 12) che
contiene le cartelle e i file necessari per sviluppare il medesimo.
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Fig.ura 12
Creazione di un file sorgente

A questo punto € possibile aggiungere o creare i file sorgenti (Source File) selezionando di
seguito File e New File dal menu principale (figura 13).

x MPLABE X IDE v3.20 - progettol : default
File Edit View Mavigate Source Refactor

1 New Project... Ctrl+ Shift+ N
9 NewFile.. <I—3 Ctrl+N
Figura 13

La creazione di un file sorgente prevede due step successivi e due conseguenti finestre.
Selezionando New File si apre la prima finestra che consente la scelta del tipo di file
(Choose File Type).

In questo caso si € scelto di programmare in Assembler (da elenco Categories); il file
sorgente ha estensione .asm (da elenco File Types).
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AN,

Q, Filter:
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I Other

Description:

iAn Assembler file with no content.

< Back Finish Cancel Help
Figura 14




La seconda finestra definisce il nome del file e la sua posizione all'interno del progetto
(Name and Location).

3 New AssemblyFile.asm *
Steps Name and Location
1. Choose File Type File Name:  sorgente]

2. Name and Location

Project: progettol

Folder: Browse...

Created File: |C:\Users\Desktop\MPLAB‘progettol.X\sorgente.asm

< Back MNext > Cancel Help
Figura 15

Il file sorgente che si trova ora nella cartella di progetto scelta in precedenza deve essere
successivamente trasferito in Source Files della finestra Projects.

Si deve evidenziare la cartella e, utilizzando il tasto destro del mouse, selezionare |l
comando Add Existing Item (figura16).
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Il trasferimento del file avviene selezionandolo dalla finestra Select Item che compare di
seguito (figura 17).
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Il file sorgente si trova a questo punto all’interno della cartella Source Files (figura 18).
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Figura 18

- Dashboard ~ (7) Navigator Gh

Un esempio di file sorgente in linguaggio Assembler viene di seguito riportato (figura 19).

| Start Page_ x W MPLAB .X_Sbore x| E apph x| & na_wAsrfvTemEI‘_apg‘asn:\ x E] ng\_c}*»\_;mTe_mplate.as_m x E] sorgente.asm x|

AsmSowce | Hstry |[@E PO SFEBR| FL( o0 @& =
| 1 #include <pl€F84.inc
2 ORG 0x000
3 iniz moviw OxFF
4 movlw 0xFO
5 moviw 0x00
& addlw 0x12

movwE oxoC

nop
& movilw 0x03
10 movwf 0x0D

11 dec decfsz 0x0D,1
12 goto dec
13 nop & 3e
14 movlw 0x00
15 movwE 0x0C
16 goto iniz
17 END
Figura 19

Impiego del simulatore

Con la creazione del progetto (step 4) é stato scelto come strumento hardware (Hardware
Tool) il simulatore (Simulator).

Per procedere con la simulazione si deve selezionare I'icona Debug Project (figura 20).
Questa prima operazione serve per verificare la presenza di errori di sintassi.

Al termine di questa operazione nella parte in basso a sinistra del video (finestra Output)
compare la dicitura Build successful nel caso di assenza di errori, la dicitura Build failed
se invece sono contenuti degli errori dei quali viene specificata la natura.

Se non sono presenti errori si pud procedere con la simulazione (nelle modalita Step Into
e Continue) utilizzando le icone che compaiono di lato a Debug Project (figura 20).

Una sessione di debug ha termine selezionando Finish Debugger Session.

Step
Pause Continue Into

AN CYTIEEL

(A T

Debug Finish  Reset  Step Step

Project Debugger Over Out
Session

Figura 20



Modalita di simulazione
La simulazione pu0 essere effettuata nelle modalita Step Into e Continue.

Modalita Step Into

L’esecuzione del programma si interrompe ad ogni riga con la possibilita di controllare lo
stato di registri e variabili.

L’avanzamento riga per riga avviene facendo click su Step Into.

Selezionando Reset il cursore si riposiziona sulla prima istruzione.

Modalita Continue

L’esecuzione del programma avviene in modo continuo.

Puo essere interrotta selezionando Pause e riavviata dal punto in cui era stata interrotta
facendo click nuovamente su Continue.

Dopo aver selezionato Pause si pud scegliere di far ripartire la simulazione dalla prima
istruzione selezionando Reset.

Visualizzazione dei risultati della simulazione
| risultati della simulazione possono essere visualizzati:

- in formato numerico;
- graficamente.

Si ha accesso ai risultati selezionando Window>Simulator o Window>PIC Memory Views
dal menu principale (figura 21).

Window
o LD Projects Ctrl+1
B Projects Ctrl+1 L’u Files Ctrle2
03 Files Ctrl+2 18] Classes Ctrl+8
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| risultati della simulazione sono visibili nella corrispondente finestra di lavoro che si apre
dopo la selezione.

Visualizzazione in formato numerico

Si procede da Window>PIC Memory Views.

Si puo ad esempio visualizzare (figura 22) il contenuto dei registri speciali (SFRs) come
il registro accumulatore, il program counter, i registri TRISA e TRISB.



SFRs x|

Lddress ¢ Name Hex Decimal Binary @ Char

, Ox00 0 gooooooo .t
[i]] INDF 0x00 0 oooooooo v.t

E B THRO 0x00 0 00000000 " "

|02 ECL 0x00 0 ooooooon Lt
a3 STATUS Oxls 24 oool1looo .t
04 F5R Ox00 0 oooooooo vLt
05 ECRTR 0x00 0 oooooooo vLt
06 PORTB 0x00 0 Q0000000 . "
|08 EEDATA 0x00 0 00000000 .7
[E] EEALDR 0x00 0 QooQoooo t. T
[N PCLATH 0x00 0 00000000 *."
0B INTCON 0x01 1 oooooool .
51 QPTION REG OxFF 255 ITLILLIT Ty
53 TRISE 0xlE 321 DEDITLIET . "
[5€ TRISB 0xFF 255 ITIITTEL "
38 EECON1 0x00 0 00000000 *.
EE] EECONZ 0x00 0 Q0000000 tLt

Memory |.9=Rs ~ | Format |Individual e

Figura 22

Selezionando Window>Simulator>IOPin (figura 23) si pud visualizzare lo stato dei segnali
presenti sui pin di ingresso e di uscita.

1/0Pins x |
Fin Mode Value Owner or Magoming
0 Dout @0 RBO/INT
1 Dout @1 REB1
2 Dout @1 RB2
RE3 Din @0 RB3
4 Din @0 RB4
5 Din @0 RB5
5 Din @0 RB6
RET Din @0 RB7
<Mew Pin=

Figura 23

Visualizzazione grafica _

L’andamento nel tempo delle degli ingressi e delle uscite pud essere visualizzato
graficamente selezionando di seguito Window>Simulator>Analyzer.

Un esempio viene riportato in figura 24.
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Figura 24



Impiego dei punti di interruzione (Breakpoints)_

La simulazione nel modo Continue pud essere interrotta automaticamente in
corrispondenza di punti particolari denominati punti di interruzione.

| punti di interruzione vengono definiti facendo click con il cursore sul numero che
contraddistingue la riga (esempio in figura 25).

In questo caso ne sono stati definiti quattro che consentono in particolare la
visualizzazione del contenuto del registro TRISB nelle quattro situazioni previste dal
programma.

StartPage x| MPLABXStore x | ®app.h x | fgi] newAsmTemplate.asm x| g newAsmTemplate.asm _ x | ki] esempiol.asm x
wmsoree | vy |[BE-E-QAUBSBE|FET oo )
i 7
2 ca
3 #include «<pléF84.inc
1 ORG 0x000
5 bsf 83,5
6 INIZ movliw OxFE
7 movwf  TRISE
a movlw 0xFD
s movwf  TRISE
movliw 0xFC
L1 movwf  TRISE =
=) movliw OxFB
13 movwf  TRISE
| goto INIZ
15 END
igura 25

| numeri di riga corrispondenti ai punti di interruzione si riconoscono in quanto, con il click,
vengono sostituiti da piccoli quadrati.

| punti di interruzione cosi definiti vengono salvati automaticamente diventando parte
integrante del programma.

| punti di interruzione si eliminano facendo click con il cursore sui quadratini.

L’esecuzione del programma riprende dal punto in cui & stata interrotta quando si
seleziona nuovamente Continue.

Selezionando di seguito Window>Debugging>Breakpoints (figura 26) si accede alla
finestra riportata in figura 27 che mostra I'elenco dei punti di interruzione in precedenza
definiti.

Window
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uﬂ Favorites Ctrl+3
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%3 Dashboard
) Mavigator Ctrl+7
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Editor Ctrl+0
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|IDE Tools =Q Watches Alt+Maiusc+2
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B Disassembl
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& Trace
Close Other Documents =
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Document Groups 3
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Documents... Maiusc+F4

Figura 26



E Mame

O Line C:\Users\Desktop\MPLAB\esempio 1.X\esempio1.asm: & - Project: esempiol
O Line C:\Users'\Desktop\MPLAB\esempio 1.X\esempio 1.asm: 10 - Project: esempio1
O Line C:\Users\Desktop\MPLAE\esempio 1.X\esempio1.asm: 12 - Project: esempio1
O Line C:\Users\Desktop\MPLAB\esempio 1.X\esempio 1.asm: 14 - Project: esempio1

Figura 27

Impiego degli stimoli (Stimulus)_

Gli stimoli sono degli strumenti messi a disposizione per simulare il comportamento del
programma in relazione a specifici ingressi quali possono essere quelli dovuti a pulsanti,
interruttori, segnali di clock.

Si consideri come esempio il programma riportato in figura 28.

StartPage x| P MPLABX Store x| @japp.h x| gl newAsmTemplate.asm x | g newAsmTemplate.asm x| ) esempioZasm x

Asmsource | Hstory |3 - M- |Q G B B0 E
1 ;accensione di due LED contr inte e
2 #include <pléFS76A.1inc
3 ORG 02000
4 bsf STATUS, REO
5 movlw o
6 movwE ee
7 movlw

movwE
5 bof

10 inizio btfse
11
12 goto
13 bof
14 bsf
15 goto
16 segue  bsf
17 bof
18 goto
19 end
20

Figura 28

Alla porta B_pin 7 viene collegato un microinterruttore.

In relazione allo stato del microinterruttore si possono accendere/spegnere due LED
collegati alla porta C_pin6e 7.

Se lo stato del pin 7 della porta B € a livello logico alto (interruttore chiuso) si accende il
LED collegato al pin 7 della porta C; viceversa (interruttore aperto), se € a livello logico
basso, si accende il LED collegato al pin 6 della porta C.

Gli stimoli vengono definiti utilizzando la finestra Stimulus che si apre seguendo il percorso
Window>Simulator>Stimulus (figura 29).

Window
Il[] Projects Ctrl+1
[ Files Ctrl+2
l@ Classes Ctrl+8
Favorites Ctrl+3
% Services Ctrl+5
%3 Dashboard
\‘_) MNavigator Ctrl+7
ﬁ Action [tems Ctrl+6
C:I Tasks Ctrl+Maiusc+6
L"'_jI Qutput Ctrl+4
Editor Ctrl+0
Debugging >
Web »
IDE Tools ¥
PIC Memory Views »
Simulator :E stimulus
Configure Window Ana.\yzer
! 10Pin
Reset Windows

Figura 29



Nel caso dellesempio (figura 30) viene definito uno stimolo di tipo asincrono
(Asynchronous) sul pin RB7.

" Stimulus xx‘
@ Asynchronous | pinfRegister Actions  Advanced Pin/Register  Clock Stimulus  Reegister Injection
Fire  Pin Action Value Unit ~ Comments
§ [E]m . T N N
B (= lre7 SetHigh
-
H

Figura 30

Lo stimolo viene reso attivo facendo click con il mouse sulle frecce (Fire) nel corso della
simulazione; il pin pud essere portato (Action) a livello basso (Set Low) o alto (Set High).
Come conseguenza della scelta operata viene modificato il contenuto del registro PORTC
(figura 31) che vale 64 nel caso di interruttore aperto, 128 nel caso di interruttore chiuso.

Stimulus | SFRs x| Stimulus | SFRs x|

@ Address ¢ HName Hex Decimal Binary @ Address ¢/ HName Hex Decimal Binary

@ EG 0xs0 128 10000000 g G 0x80 128 10000000
aoo INDF 0x00 [1] 00000000 Qoo INDF 0x00 [ Q0000000

% aol TMRO 0x00 [ 00000000 % ol TMRO 0x00 [ Qoao0oo0

— [002 PCL Ox04 10 0ooo1010 — (002 PCL 0x0D 13 00001101
ao3 STATUS 0x15 24 00011000 ao3 STATUS 0x1§ 24 00011000
004 F5R 0x00 0 Q0000000 004 F5R 0x00 [1] 00000000
aos PORTA 0x00 [ 00000000 aos PORTZ 0x00 [ Qo0o00o00
(3 20RTH Ox00 1] Q0000000 aoe FORTE 0x30 128 10000000
ao7 20RTC Oxdio [N | 01000000 o7 I @T Uxsu e | 10000000
[N ?CLATH 0x00 0 Q0000000 [N PCLATH 0x00 [ 00000000

Figura 31



